Как я могу восстановить предыдущую версию файла?

Я изменил .тхт файл и сохранили его. Когда я снова открыл ее, я увидел, что я удалил одну вещь из последней версии я спас. Поэтому я хотел бы знать, если я могу восстановить то, что я удалил?

Этот файл очень важен для меня. Вы должны помочь мне! Моя жизнь на этот файл.

Я ничего не удалять, я редактировал только файл. Когда я пытался спасти я получаю сообщение об ошибке говорящее, что он не может читать некоторые персонажи, так что я закрыл редактор, и когда я снова открыл его некоторые линии просто исчез.

+584
taxist 14 авг. 2012 г., 8:50:12
20 ответов

Набрав

жить

не работает для меня на данный момент, но печатать

помогите

сделал. Эта ошибка, кажется, наиболее подробно обсуждали здесь: https://bugs.launchpad.net/ubuntu/+источника/через USB-создатель/+ошибка/645818

Надеюсь, что публикуя этот метод может помочь кому-то решить эту немного быстрее, что я сделал!

+868
Mohammed Shaqeeb 03 февр. '09 в 4:24

Мне нужно ограничить/запретить пользователям доступ к "настройки системы" в интерфейсе ?

+808
Lee Neas 8 окт. 2016 г., 9:46:50

Я использую Кубунту начиная с 9.04, но я решил перейти на Ubuntu (читай: гном) сейчас. Я установил Убунту-десктоп некоторое время назад, я думаю, что система была в 9.10 потом. Я сейчас в 10.10, все через обновления (не переустановки).

Предположительно, из-за этого я пропустил несколько вещей в моей гном по сравнению с чистой установки операционной системы Ubuntu 10.10:

  • Уведомления (МСН контакт онлайн, низкий заряд батареи и т. д.) посмотрите стиля. Они выглядят как текстовые облака вместо блестящей кроме коробки. Вот как они выглядят:

Ugly Notification

  • Я потерял мое имя и параметры завершения работы в правом верхнем углу панели

Как я могу восстановить эти?

+748
Rian Webster 16 мая 2014 г., 14:36:04

Как установить драйверы NVIDIA для Ubuntu 12.10? У меня GeForce 540m и GT и пытался сделать это за последние 2 месяца, не повезло. Я попробовал официальном репозитории, то я добавил х сват ППА. Я установил Linux-заголовков-универсальный и Linux-источник, и практически каждое решение Google может предложить. На протяжении этого мне должны сделать по крайней мере 25 переустановку операционной системы Ubuntu; кто-нибудь еще(с 540m и GT) есть эта проблема?

+715
AndyEken 24 сент. 2017 г., 18:08:29

(этот пост содержит так же, как и мой предыдущий пост о жратве спасательных проблема после установки Убунту 12.04 ЛТС с тех пор как я разместить его на том месте)

Слава богу я нашел на этой странице. Я Ньюби из Индонезии, а у меня ноутбук с 2 операционки (7 и точно установлен). Я установил Ubuntu 12.04 вручную путем замены Blankon 4.0 (в Ubuntu на основе индонезийской дистрибутив) раздел. Я сделал /загрузки монтирования, а затем выбрал его в качестве места для bootloading. Как результат, я испытываю ошибка 15 до сих пор, и у меня загружается мой ноутбук из программы каждый раз, когда я хочу использовать его. Есть ли способ решить проблему? Терима касих (спасибо)

+674
Tibi02 1 июн. 2012 г., 23:23:33

Я пытаюсь загрузить пакет на ППА, но я получаю сообщение об ошибке (в конце этого поста). Я создал ППА и попытался загрузить подписанный пакет, и я получил ошибку. Я думал, что это потому, что у меня нет ключа SSH в настройках, так что я добавил один. Но проблема по-прежнему здесь.

Что нужно сделать, чтобы загрузить мой пакет с ППА?

Бессарабов@Бессарабов-Примечание:~/tmp/и delete_after_2011-05-08$ действия dput НПА:Бессарабов/звезда libsql-простой perl_0.02-1_i386.изменения
Проверка подписи на .изменения
у GPG: подпись сделал вс 08 май 2011 01:36:39 вечера МСД с помощью RSA ключа 79B2238B
GPG: действительная подпись от "Иван Бессарабов "
Хорошая подпись /домашний/Бессарабов/ТМП/delete_after_2011-05-08/libsql-простой perl_0.02-1_i386.изменения.
Проверка подписи на .ДСК
у GPG: подпись сделал вс 08 май 2011 01:36:24 часов МСД с помощью RSA ключа 79B2238B
GPG: действительная подпись от "Иван Бессарабов "
Хорошая подпись /домашний/Бессарабов/ТМП/delete_after_2011-05-08/libsql-простой perl_0.02-1.ДСК.
Загрузка на ППА (через FTP ppa.launchpad.net):
 Загрузка libsql-простой perl_0.02-1.ДСК: сделано.
 Загрузка libsql-easy-perl_0.02-1.tar.gz: сделано.
 Загрузка libsql-простой perl_0.02-1_all.деб: сделано.
 Загрузка libsql-простой perl_0.02-1_i386.изменения: 1к/2k550 изменения файла должны быть подписаны действительным ГОБ подпись: не удалось выполнить проверку в 3 раза: ["(7, 9, у строительно открытого ключа')", "(7, 9, у строительно открытого ключа')", "(7, 9, у строительно публичный ключ')"] : в разрешении отказано.
Примечание: эта ошибка может указывать на проблему с настройками passive_ftp.
 Пожалуйста, проконсультируйтесь действия dput.БФ(5) подробности об этом варианте конфигурации. Бессарабов@Бессарабов-Примечание:~/tmp/и delete_after_2011-05-08$
+672
colbarry 3 нояб. 2010 г., 22:12:42

Как установить платформа Haskell для Ubuntu 13.04? Я получаю следующую ошибку, когда я ввожу команду sudo apt-получить установку Хаскелл-платформа:

Е: не удалось найти пакет Хаскелл-ошибка платформы 
+589
hungryformath 14 окт. 2010 г., 9:47:00

У меня есть собственные приложения упакованы с помощью dpkg. Приложение зависит от нескольких .deb файлы, которые я пытаюсь установить из скрипта preinst мое заявление. Сценарий preinst скрипт проверяет, если зависимый деб файл устанавливается, если оно не выходит установить его с помощью команды dpkg -я команда. Это повторяется для всех зависимых деб файлы, необходимые для основного приложения.

Когда я пытаюсь установить основное приложение с помощью команды dpkg -якоманды возвращает сбой при попытке выполнения сценария preinst. Ниже это сообщение об ошибке:

с dpkg: ошибка: база данных состояния dpkg-это заблокирован другим процессом

Я удалил каталог/var/lib в/с dpkg/блокировки файла и повторно установить приложение. Но безрезультатно. Если я запускаю сценарий preinst скрипт отдельно, как и любой другой скрипт, он работает без каких-либо проблем. Все deb файлы будут установлены правильно. Поэтому речь идет только тогда, когда этого сценария preinst выполняется автоматически с помощью команды dpkg -i команда.

Я заблудился, пытаясь определить причину. Если кто-то может пролить некоторый свет на то, что реальная проблема может быть, их помощь будет принята с благодарностью.


Спасибо, ObsessiveSS0F за Ваш быстрый ответ.

Я понимаю, о чем вы говорите, но это не поможет моей ситуации. Позвольте мне рассказать вам, почему.

  1. Скажи Мое основное приложение (давайте mainapp.деб) зависит от пяти других .deb файлы
    (скажем, 1.деб, 2.Деб и так далее).
  2. Зависимой .deb файлы-мое личное пакетов/библиотек. Так это не загружаемые из интернета. Так, я не могу использовать apt-get установить их автоматически.
  3. Я бы сделал "зависит от поля" в файле управления, чтобы указать на 1.деб, 2.Деб..и т. д. но как вы знаете команды dpkg -я без автоматической установки зависимостей.
  4. Я могу выполнить команду dpkg -i, после чего apt-получить -Ф установить, но для apt-приступить к работе, я нужно отредактировать /etc/АПТ/источников.файл списке, чтобы добавить ссылку на локальный каталог в системе, где зависимой .хранить деб файлы.
  5. Ну, #4, кажется, работает, но это не вариант для меня, потому что это приложение будет установлен на многих серверах, и программа установки должен быть полностью автоматизирован.

Я продолжала расследовать причину preinst нового пакета был не в состоянии установить .deb файлы и я думаю, я выяснил почему.

  1. Когда я запустить dpkg -я mainapp.деб,процесс dpkg-это создание в /var/lib в/с dpkg/замок
    и некоторые файлы в /var/lib в/dkpg/обновления каталога.
  2. Теперь, сценарий preinst скрипт имеет ряд команд dpkg-я команды для установки зависимая
    .deb файлы. Поэтому, как только первые команды dpkg -я команда в скрипта preinst является выполнен он не из-за замков, созданных ранее командой dpkg.
  3. Похоже, что две команды dpkg не может выполняться параллельно из-за замков.

Я модифицировал скрипт preinst нового пакета для резервного копирования замков, созданных процессом dpkg для временной папке и удалил оригинальный замки. (команда lsof выводит сообщили, что замки были удалены). Теперь, когда замков не было, команда dpkg -я команды в сценарий preinst скрипт выполнен без каких-либо проблем. Я восстанавливал замки обратно перед выходом из скрипта preinst так, что главную команду dpkg -i команда могли продолжать. Он работал, но у меня есть ощущение, что это не правильный подход.

Я все еще пытаюсь выяснить альтернативные способы установки .файл deb вместе с его зависимостями.

+469
Joshua Dawson 23 мар. 2018 г., 22:14:07

удалить файл config для программного обеспечения-центр, затем выйдите из системы и обратно в

судо РМ -РФ ~/.конфигурации и программного обеспечения-центр
+465
user82727 9 сент. 2018 г., 10:34:05

Обновил до 11.10, но я получаю сообщение

Ошибка:BrokenCount>0

Следующие пакеты имеют неудовлетворенные зависимости:

libvte-общие: 

Когда я иду в центр программного обеспечения я не могу добавить, удалить или обновить, он говорит мне, чтобы запустить следующую команду в терминале: apt-получить установку -Ф что получает меня нигде как я не знаю, что делать дальше.

Также сообщение, что каталог пакет нуждается в ремонте, но ничего не получается, когда я нажимаю на ремонт бара.

installArchives() не удалось: (чтение базы данных ... 
(Чтение базы данных ... 5%
(Чтение базы данных ... 10%
(Чтение базы данных ... 15%
(Чтение базы данных ... 20%
(Чтение базы данных ... 25%
(Чтение базы данных ... 30%
(Чтение базы данных ... 35%
(Чтение базы данных ... 40%
(Чтение базы данных ... 45%
(Чтение базы данных ... 50%
(Чтение базы данных ... 55%
(Чтение базы данных ... 60%
(Чтение базы данных ... 65%
(Чтение базы данных ... 70%
(Чтение базы данных ... 75%
(Чтение базы данных ... 80%
(Чтение базы данных ... 85%
(Чтение базы данных ... 90%
(Чтение базы данных ... 95%
(Чтение базы данных ... 100%
(Чтение базы данных ... 263371 файлы и каталоги установлены.)
Готовится сменить libvte9 1:0.27.90-0ubuntu1 (используя .../libvte9_1%3a0.28.2-0ubuntu2_i386.деб) ...
Распаковка замена libvte9 ...
архив с deb (подпроцесс): данных: внутренняя ошибка gzip в читать: '<ФД:0>: ошибка данных
архив с deb: ошибка: подпроцесс <распаковки> возвращен код ошибки 2
с dpkg: ошибка при обработке в /var/кэш/АПТ/архив/libvte9_1%3a0.28.2-0ubuntu2_i386.деб (--распаковать):
 подпроцесс dpkg для-деб ... фпму-архив возвращен код ошибки 2
Нет отчета Аппорт написал, потому что сообщение об ошибке указывает на проблему в локальной системе
Ошибки возникли при обработке:
в /var/кэш/АПТ/архив/libvte9_1%3a0.28.2-0ubuntu2_i386.деб
Ошибка в функции: 

Любая помощь, пожалуйста? (пожалуйста, назови его, как в принципе, как это возможно!)

+465
Tlacenka 2 янв. 2015 г., 2:53:29

Я установил приложение Nemo (форк Наутилуса, созданный командой Линукс Минт) в Моя Ubuntu 12.04.1 LTS с оболочки GNOME 3.4.2. Я следовал инструкциям DefaultFileManager на help.ubuntu.com изменение "узлов" и "X-каталога" в файл "по умолчанию.список", чтобы сделать Немо мой файловый менеджер по умолчанию.

Теперь все работает отлично, кроме одного: при открытии папки с рабочего стола.

Я поставил опцию "есть файловый менеджер обработает рабочий стол" на. Круто. Проблема в том, что на рабочем столе, кажется, обрабатываются только Наутилус, даже если я поставил другой файловый менеджер по умолчанию. Каждый раз, когда я дважды щелкните папку на рабочем столе, он открыл Наутилус, а не Немо.

Кто-нибудь знает как это исправить?

+456
Chick 8 июл. 2015 г., 13:39:06

Когда я запускаю Убунту твик из тире, настройки системы или терминала, он сразу падает.

Я получаю этот код ошибки из терминала:

Обратная трассировка (самый недавний призыв последнего): 
 Файл "/usr/Бен/Убунту-твик", линии 124, в <модуль>
 из ubuntutweak.основной импорт UbuntuTweakWindow
 Файл "/usr/lib/python2.7/dist-packages/ubuntutweak/main.py", линия 33, в <модуль> 
 из ubuntutweak.приложения импорт AppsPage 
 Файл "/usr/lib/python2.7/dist-packages/ubuntutweak/apps/__init__.py", линия 19, в <модуль> 
 из ubuntutweak.средства policykit.dbusproxy импорт прокси
 Файл "/usr/lib/python2.7/dist-packages/ubuntutweak/policykit/dbusproxy.py", линия 22, в <модуль> 
 от импорта из INT_MAX 
ImportError: не удается импортировать имя из INT_MAX

Любой способ, чтобы исправить это, кажется, легко исправить импорт?

+429
BoredToolBox 3 апр. 2010 г., 19:44:55

Возможные Дубликаты:
для amd64, i386 с (32бит / 64бит) - какую версию выбрать?
Разница между архитектурами i386 и для amd64?

Когда я хочу, чтобы начать загрузку рабочего стола в Ubuntu 12.10 64 bit, он напрямую хотите скачать amd64 в ИСО. Это значит, что существует также версия Intel ? Если да, то где ее можно найти ? У меня процессор Intel core2duo T9300 2.50 ГГц, так что он может работать в 64-разрядной версии.

характеристики: http://ark.intel.com/products/33917/Intel-Core2-Duo-Processor-T9300-6M-Cache-2_50-GHz-800-MHz-FSB

Спасибо заранее

+327
avinash kumar 23 нояб. 2011 г., 8:27:55
Вопросы о MailScanner и электронной почты системы безопасности
+305
iCodeForFood 11 февр. 2010 г., 7:34:46

Кто-нибудь знает, как установить драйверы для Epson стилус NX125 все в одном принтер/сканер в Ubuntu? Мой Windows XP с жесткого диска был атакован вирусом и он запер своего приложения, так что мой кузен установил Ubuntu на мой второй 20 гиг диск для доступа к электронной почте/интернет

+249
etacarinae 3 мая 2019 г., 16:39:06

Я вижу это нежелательное поведение с тех пор единства в Ubuntu. Лаунчер единство случайно "ворует" конечную точку для минимизации анимации от босс. Другими словами, когда я нажимаю на значок в docky для минимизации окна, то окно сворачивается в единство, а не босс. Что происходит в большинстве случаев на все окна, хотя иногда и случайным образом, случается, что Windows минимизировать, чтобы босс, но очень редко.

Вот как это выглядит, когда я свернуть окно: enter image description here Вот как обе анимации должен выглядеть: enter image description here

+233
Petschko 3 февр. 2010 г., 5:09:30

вы должны использовать утилиту диска, чтобы сделать разделов (первичных и логических) затем с помощью загрузочного диска с USB-создатель

+177
Alphimeda 22 нояб. 2013 г., 14:10:24

Я установил мой NVIDIA , и это работает. Мой компилятор CUDA в Ubuntu сейчас работает.

Теперь, я не хочу сотуары обновить NVIDIA на всех... , как я могу заставить программного обеспечения Центр обновления моей карты Nvidia графика вообще? Если кто-то знает как удалить автоматическое обновление из Центра программного обеспечения, пожалуйста, дайте знать.

+174
Rich Gilberto 7 окт. 2013 г., 22:01:58

Есть ли программа для Linux, которая имеет примерно такую же функциональность и удобство использования как в OneNote? На данный момент я проверяю корзину (для KDE), что, похоже, точку в правильном направлении, но еще не хватает много функций OneNote и очень глючный, к сожалению.

Для тех из вас, которые не знают, что OneNote-это, вот первый абзац из Википедии запись:

Майкрософт OneNote (прежнее название Майкрософт Офис программа OneNote) - это компьютерная программа для свободной формы сбор информации и Multi-пользователей сотрудничество. Он может собрать пользователя заметки (рукописные и машинописные), рисунки и аудио комментариями и делиться ими с другими пользователями Майкрософт OneNote через Интернет. Настольной версии OneNote-это доступные для Майкрософт Windows платформа.

+99
Wolf161 4 нояб. 2017 г., 4:29:25

Сколько эти шаги вы следовали?

От: wiki.ubuntu.com > обновление с Ubuntu 10.04 LTS на Убунту 12.04 ЛТС

Для обновления с 10.04 LTS для настольных компьютеров до обновления по сети с помощью следующей процедуры.

  1. Пуск Система/Администрирование/Источники Приложений
  2. На вкладке Обновления, установите флажок показывать новые выпуски рассылки: на длительный срок поддержки релизов, затем нажмите закрыть.
  3. Нажмите Alt-F2 и введите обновление-менеджер -д
    1. Нажмите кнопку Проверить, чтобы проверить наличие новых обновлений. Если есть какие-либо обновления для установки, используйте повторно установить кнопку, чтобы установить их обновления, и нажмите Проверить после этого.
    2. Появится сообщение, информирующее вас о наличии новой версии. Нажмите Кнопку Обновить. Следуйте инструкциям на экране.

Для достижения наилучших результатов, вы должны быть полностью обновляются ( 10.04.4) перед началом.

+34
CMilton 20 июл. 2010 г., 17:34:55

Показать вопросы с тегом