Как настроить маршруты для моего VPN-подключение

В моем предыдущем вопросе я спрашивал о настройке vpnc связи. Я установил сеть-менеджер-vpnc так что теперь я могу настроить все эти вещи прямо от сети менеджером.

Я получил эту красивую картинку из смежной теме:

I have got this pretty picture from related topic:

Так что вопрос, как выяснить, что адрес, маску и шлюз я должен использовать только этот трафик через VPN.

В качестве основы у меня есть айпи и порт внешнего сервиса, который я хочу использовать через vpnc. Так инернете и остальной трафик должен идти как всегда через Ethernet или WiFi.

  • Внешний IP: 10.20.30.40
  • Порт: 1433 (это на самом деле SQL сервер)
+366
Justin Jacobeen 18 мар. 2012 г., 19:34:16
27 ответов

завиток-погрузчик - это генератор трафика. Вы можете создавать HTTP и HTTPS, FTP и т. д. трафик с него.

Добавьте к этому, можно смоделировать несколькими клиентами (несколько IP-адресов источника).

Вот объяснение того, как установить curl-loader на машину Ubuntu 12.04 64bit и генерировать HTTP, HTTPS-трафик.

$ uname –Р
3.2.0-39-generic и

$ хвоста -1 /и т. д./ЛСБ-релиз
DISTRIB_DESCRIPTION="Убунту 12.04.2 ЛТС"

установить curl-погрузчик

  1. скачать керл-погрузчик с http://curl-loader.sourceforge.net/
  2. Я скачал завиток-погрузчик-0.56.тар.bz2 файл.
  3. экстракт

    завиток-погрузчик-0.56 bunzip2.тар.bz2, что
    завиток-погрузчик-0.56 дегтя xvf.тар
    компакт-скручиваемость-погрузчик-0.56/
    
  4. строительные требования

    Построить его, используя общие с среде разработки с bash, ССЗ (3 или 4 серии), сделать и т. д. На машине с Linux.

    Здание pre-требования:

    • в OpenSSL файлы;
    • разработки пакета OpenSSL с включаемых файлов (на libssl-dev пакет для Debian);

    У меня не установлен libssl-dev , поэтому я установил libssl-dev, которая перед компиляцией завиток-погрузчик.

    судо apt-получить установку libssl-dev и
    
  5. компиляции

    $ фрд
    /главная/Хаттори/My_works/завиток-погрузчик-0.56
    
    $ сделать
    [...]
    /Бен/Ш: 2: исправление: не найден" и "Make: *** [библиотека lib/libcurl использует.а] ошибка 127
    

Как мне поступить с этой ошибкой?

+980
LaurenP 03 февр. '09 в 4:24

У меня есть маленький вопрос, есть способ, чтобы изменить цвет или тень от выступа на Наутилус элементарного?

Например, у меня две вкладки открыты, но я не могу различить.

Я посмотрел файл gtkrc из этой темы, и изменил цвет от линии 288,289, но это изменение "цвета" на других окнах, а не на Наутилус

+978
Caltain 19 мар. 2018 г., 12:52:46

Решение (по крайней мере для Ubuntu 11.10 онейроидного оцелот):

судо apt-получить установку libunity6

Чтобы найти пакет из установленное файлом:

$ dpkg для -С libunity6
libunity6: в /usr/lib в/libunity.так.6

Чтобы найти пакет отсутствует файл:

  1. Перейти к http://packages.ubuntu.com
  2. Прокрутите вниз до "поиск по содержимому пакетов" и введите имя файла, например, libunity.так.6

..и вуаля!

+961
qstack 14 авг. 2015 г., 13:46:09

В конце концов я использовал выскочка в /etc/инит/в MongoDB.файл conf и он работал хорошо.

+953
Ohforf 12 авг. 2014 г., 9:17:49

Я переехал мой сервер в другой офис. Поскольку они хотели, чтобы открыть его, я присоединился к своей сети путем изменения IP моего сервера. На сервере размещаются лампы + Постгреса.

Теперь я не могу получить простой веб-приложения для запуска. Даже pgAdmin попробуйте со своего ПК на сервер не будет работать. Это все в локальной сети?

В чем может быть проблема?

Например: /phppgadmin

не будет работать. даже не в этом index.html это показывает, что 'это работает'.

ПОДРОБНЕЕ:

Я просто понял, что это... когда я отключить мой брандмауэр

НПВ отключить

У меня нет проблем. Как я могу позволить этому работать с брандмауэр? Я помню, позволяя порт 22, но это, кажется, не имеют эффекта. Может, что-то я делаю неправильно.

+909
KSW 9 дек. 2010 г., 17:39:12

Vimprobable, легкий в WebKit-браузер, клавиатура с приводом. Ссылки активируются нажатием клавиши, которая запускает "намек" - число рядом с каждой ссылкой, которая вносится, чтобы активировать ссылку.

Это быстрый, стабильный и не требует грызуна.

Vimprobable

+744
Muhammad Raheel 2 мар. 2014 г., 16:31:29

Предполагая, что вы используете браузером. Вы будете иметь для подключения к нагрузке-статус собственность сигнал, чтобы увидеть, если новая страница запрашивается и изменить netry соответственно.

Вот кусок кода из старого проекта шахты.

 # Срезанный инит и прочее...
 самовывоз._webview = в WebKit.Объект WebView()
 самовывоз._webview.подключение('уведомления::нагрузка-состояние, проблемы.on_load_status)

деф on_load_status(самовыдвижение, объект WebView, статус):
 статус = объект WebView.get_load_status()
 если состояние == в WebKit.LoadStatus.Совершено:
самовывоз._set_loading(правда)
самовывоз.Шаблон _entry.set_text(объект WebView.get_uri())
 Элиф состояние == в WebKit.LoadStatus.Закончил:
самовывоз._set_loading(ложные)

деф _set_loading(самовывоз, погрузка):
самовывоз._стоп.set_sensitive(погрузка)
 самовывоз._reload.set_sensitive(не загружается)
самовывоз._back.set_sensitive(самовыдвижение._webview.can_go_back())
самовывоз.Начинается только.set_sensitive(самовыдвижение._webview.can_go_forward())

В _set_loading() метод используется для включение/выключение остановка/перезагрузка/назад/вперед кнопки на панели инструментов. Если у вас их нет, оставьте его (в противном случае, изменения имен для ваших нужд, конечно).

+743
Phil Hood 23 окт. 2018 г., 6:41:41

Вы можете использовать выход с помощью dpkg -с <имя_пакета> или с помощью dpkg-запрос -л <имя_пакета>

в скрипте для этой цели.
Вежливость:https://stackoverflow.com/questions/1298066/check-if-a-package-is-installed-and-then-install-it-if-its-not

например

#!/Бен/ш

для P; делать
 команды dpkg -С "$Р" >/dev/нуль 2>&1 && {
 Эхо "$P устанавливается."
 } || {
 Эхо "$P не установлен".
}
сделано

Использование: script.sh пакет1 упаковке2 .... packageN

Вежливость:https://stackoverflow.com/a/10594734/749232

+708
user2874184 3 сент. 2019 г., 17:23:31

Это просто файловая система проверки, или проверки; это не имеет ничего общего с плохими секторами. На основе ваших tune2fs выхода, похоже, что вы решили отформатировать диск с файловой системы ext2, а не ext3 или ext4. Вы должны повторно установить и использовать рекомендованные по умолчанию файловая система ext4.

+684
Judy Ann Bergantin Salopaso 3 февр. 2011 г., 15:01:56

Это невозможно, потому что Unix-версии не предназначены для работы, как это. Как правило, все исполняемые файлы в небольшое количество каталогов. Например, все вещи, которые я пишу для моих собственных целей идет в ~/бин.

Если вы не хотите, чтобы ваши фактические двоичные файлы и скрипты для видео в папку bin, вы можете создать символическую ссылку на, например, ~/bin в реального.

Имея все подкаталоги в $Path не особенно желательно, так как он просто добавляет дополнительные каталоги для поиска, повышает риск другие исполняемые файлы, получить в вашем пути, которые не должны быть там, и действительно не дает особой выгоды.

+660
Harsh Gopal 26 июл. 2014 г., 17:46:34

Вы бы сначала нужно создать какой-то метод, чтобы показать уведомление. Самый простой способ сделать это было бы создать простую HTML-страницу и отобразить его для пользователя с помощью браузера Firefox file:///home/user/legal_notice.html (из терминала).

Если вы можете продолжить, чтобы добавить его в качестве запуска приложений, используя следующий метод: http://xubuntugeek.blogspot.nl/2011/12/add-application-to-xfcexubuntu-session.html

Кроме того, вы должны быть абсолютно уверены, что ваше уведомление не конфликтует с лицензиями программного обеспечения в Ubuntu (такие как, но не ограничивается лицензией GPLv2).

+589
Sharlike 6 июл. 2017 г., 6:19:58

Я не если это правильное место, чтобы задать этот вопрос, поэтому, пожалуйста, дайте мне знать, если я могу получить лучший ответ в другом месте.

Я недавно переехал на Ubuntu 11.04 с Windows Виста.

Я использую Firefox с Автопрокси + СШ довольно долго в Vista, и это работает прекрасно.

Но в Ubuntu в автоматическом режиме из Автопрокси на самом деле превратилось в глобальный режим, который использовать SSH прокси для каждого сайта, я иду, и это значительно замедляло работу серфинга скорости. И глобальный режим по-прежнему работает вглобальном режиме.

Я понятия не имею, почему это происходит. Так может кто-нибудь дать мне подсказку ?

Спасибо заранее.

+579
daviswen 23 июн. 2010 г., 4:28:04

Я использую классический GNOME. Нет сочетание клавиш Ctrl+клавиши Alt+влево/вправо ярлык в Параметры системы -> Клавиатура -> Сочетания клавиш.

enter image description here

Оно должно быть настроено где-то еще. Но где?

+567
Sneha Thomas Mathew 19 нояб. 2012 г., 12:18:45

Если вы хотите расширить свой /загрузки, вам необходимо сжать раздел, следующий (или предыдущий) к /загрузочного раздела.

Если вы секционированных диске как файл/boot (sda1, поскольку) и / (sda2):

  1. Резервного копирования данных. Я никогда не терял данных, когда с помощью GParted, но вы можете иметь меньше удачи, если есть сбой питания или других аппаратных средств ошибка.
  2. Загружается прямо с компакт-диска без установки каких-либо файловых систем
  3. (опционально) обновить источники приложений и GParted, это гарантирует, что у вас последняя версия из репозиториев доступны:

    судо apt-получить обновление && судо apt-получить установку программы GParted
    
  4. Термоусадочная sda2 на левой стороне, чтобы выделить место для /загрузки
  5. Расширять будут sda1 , чтобы заполнить выделенное пространство.
  6. Применить изменения

Никаких дальнейших действий, как харчи-установки не требуется, так как вы не удалили раздел, и, следовательно, идентификатор UUID раздела и номер устройства не меняется.

+412
Murokas 14 окт. 2013 г., 3:30:21

Попробовать

nodejs --версия

(по крайней мере на моей системе бинарные называется nodejs)

+404
Apostolos Apostolidis 6 мая 2011 г., 2:35:54

Попробовать опцию восстановления в меню grub при загрузке-просто включите сеть и исправить сломанные пакеты, чтобы закончить обновление. Или еще

  • суда apt-получить установку профпригодность && судо способность безопасные обновления
  • суда apt-получить обновление -Ф && судо apt-получить -Ф установите
+378
Skymask 29 авг. 2011 г., 21:58:51

Отличный вопрос.

Нагрузок

В /usr/доли/xdiagnose/нагрузки справочник имеет набор рабочих нагрузок, предназначенных для реализации вашей графической системы, чтобы вызвать зависание.

$ Общ /usr/доли/xdiagnose/нагрузок/
Ридми do_monitor_rotation_loop
do_chws_loop* do_screensaver_loop*
do_cpu_spin_loop do_video_loop*
do_disk_write_loop do_vtswitch_loop*
do_glx_loop* repro.sh
do_kernel_compile_loop run_workloads
do_monitor_disable_loop* youtube-loop.html
do_monitor_resolution_loop* youtube-reload.html

Обратите внимание, что для запуска им нужно пройти "бег". Е. Г.:

$ do_glx_loop работать

Без аргументов сценарии будет использование дисплея. Отчасти это для безопасности (в случае если человек просто слепо выполнять сценарии), но в основном это для скриптов API и аккуратно.

Те, что я снялся, наверное, самые лучшие для начала. Я хотел запустить только один сценарий за один раз и отпустить ее несколько часов. Если ваша система переживет достаточно хорошо, то попробуйте запустить два или более одновременно.

Обратите внимание, я не проверял эти супер сильно себя, поэтому не могу обещать, что они свободны ошибок. Но они довольно короткие и простые скрипты, так что надеюсь, легко исправить вверх, а также патчи очень приветствуется.

Также отметим, что они вполне вероятно могут вызвать зависания связаны с одним вы пытаетесь решить. ГПУ зависаний вообще все выглядят одинаково для неопытного глаза, поскольку они имеют точно такие же симптомы, более или менее.

Журналы

Если вы находитесь на видеокарты Intel, есть файл /sys/ядра/отладки/Дри/0/i915_error_state, что вы хотите. Это снимок регистра состояния на момент зависнуть, а в верхней части он содержит некоторые коды ошибок. IPEHR, PGTBL_ER, СОЭ, ЭИР. Матч этих кодов, чтобы увидеть, если у вас такие же или похожие ошибки.

Если вы не на графику Интел (как в данном случае не вы), или если вы не видите i915_error_state файлов, то файл dmesg и /VAR/журнал/Керн.журналов, что смотреть. Иногда с GPU зависания они указывают на то, что ГПУ решеткой была вызвана или.

С открытым исходным кодом -драйвер ATI имеет radeontool и avivotool, которые захватывают государствами зарегистрироваться. Это в первую очередь с открытым исходным кодом от ATI, но эти инструменты должны также работать с fglrx от. Я никогда не видел, чтобы она просила по -fglrx от ошибок, но это, конечно, не повредит.

Тестирование

Для всех водителей, следующим шагом является, как правило, чтобы начать тестирование либо новой или более старой версии драйвера. Для проприетарных драйверов, вы можете проверить х-обновления ППА, но, вероятно, вам придется скачать и вручную установить драйвера с сайта производителя (и испортить упаковку вашей системы в этом). Для водителей Фосс как -Интел-нуво, -АТИ, что означает тестирования или новые ядра или новее Меса. Мы предлагаем пакетированные сборки новых ядер в http://kernel.ubuntu.com/~ядра-НПА/магистральных/. В Mesa, существуют различные ППД, таких как файла xorg-обрезки. Я тоже в процессе подготовки обновления 8.0.3 для точного, который мы считаем исправлены некоторые зависания для видеокарты Intel.

В любом случае, не просто останавливаться, когда вы найдете вариант, который работает. Попробовать другие версии между рабочей версией и сломанной один. Если вы можете сузить кронштейн вниз, чтобы две соседние версии, что может быть чрезвычайно полезным для разработчиков и описывать, какой патч регрессу.

Войска

Как вы идете по устранению неполадок вы можете обнаружить ошибки, или, возможно, придумаете улучшения для скриптов или документов. Вклад в любой из них тепло приветствовал. С Вики-документы, пожалуйста, просто идти вперед и изменить! Я стараюсь обновлять их хотя бы раз в год, но я не всегда доходили руки до этого, а следующий парень, чтобы посетить страницу, безусловно, ценим ваши усилия на их улучшение.

Для изменения в Скрипты сами по себе, тоже вполне приветствуется. Пришлите мне изменения, однако, вы чувствовали себя комфортно - как патчи, а БЗР или ветку в Git, или даже просто копии скриптов. Если вы планируете делать много изменений, ветки bzr с предложением слияния является предпочтительным способом; уроки о том, как это сделать, доступны в code.launchpad.net или не стесняйтесь, чтобы поймать меня на IRC, если у вас есть вопросы.

Или, если вы не готовы копаться в программировании но хотел бы, чтобы флаг ошибки или районы, где больше возможностей, вы можете подать отчеты об ошибках обычным способом (в Ubuntu-ошибка xdiagnose).

Быстрые Исправления

Если вы не заинтересованы в любой из вышеперечисленных отладки, вот некоторые случайные советы:

Для проприетарных драйверов, попробуйте удалить и продувки их полностью из вашей системы, после переустановки с нуля. Это, к сожалению, "решает" очень много багов...

Для драйверов Фосс, существуют различные коммутаторы ядра вы можете поиграть со. Для 3D/ошибки Меза, там тоже driconf для настройки различных параметров.

Наконец

Наконец, одна просьба... пожалуйста, не файл сообщения об ошибке на Launchpad о "случайных зависает", пока вы не сделали хотя бы немного покопавшись такие, как описано выше. В противном случае, вы бы просто добавить к шуму.

Мы стараемся, чтобы рыба хорошо изучены отчеты об ошибках; мы находим их, чтобы дать более высокую отдачу, и гораздо более вероятно, в конечном итоге с реальным фиксировать к дистрибутиву.

+373
Jan Doe 14 февр. 2010 г., 21:31:49

Недавно я обновил свою Убунту до 12.04. Пока что, я не могу использовать Synaptic вообще.

После попытки устранить проблему через синаптикс, он возвращает мне:

 installArchives() не удалось: команды dpkg: проблемы зависимостей предотвратить конфигурации wine1.4-для i386:i386 с:
 wine1.4-для i386:i386, который зависит от wine1.4-Общий (= 1.4.1-0ubuntu1~precise1~ppa3); однако:
 Версии wine1.4-на общей системе составляет 1,4-0ubuntu4.
с dpkg: ошибка обработки wine1.4-для i386:для i386 (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4:
 wine1.4 зависит от wine1.4-amd64 (о= 1.4-0ubuntu4); однако:
 Версии wine1.4-amd64 на системе 1.4.1-0ubuntu1~precise1~ppa3.
 wine1.4 зависит от wine1.4-для i386 (= 1.4-0ubuntu4); однако:не доклад Аппорт написано, потому что MaxReports уже достиг 
Нет отчета Аппорт написано, потому что MaxReports уже достиг 

 Пакет wine1.4-для i386 не установлен.
 Версии wine1.4-для i386:i386 на системы 1.4.1-0ubuntu1~precise1~ppa3.
с dpkg: ошибка обработки wine1.4 (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4-Общий:
 wine1.4-Общий зависит от wine1.4 (= 1.4-0ubuntu4); однако:
 Пакет wine1.4 еще не настроена.
с dpkg: ошибка обработки wine1.4-Общий (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4-для amd64:
 wine1.4-amd64 в зависимости от wine1.4-Общий (= 1.4.1-0ubuntu1~precise1~ppa3); однако:
 Версии wine1.4-на общей системе составляет 1,4-0ubuntu4.
с dpkg: ошибка обработки wine1.4-amd64 (о--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурация вина:
 вина зависит от wine1.4; однако:
 Пакет wine1.4 еще не настроена.
с dpkg: ошибка при обработке вина (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: доклад Аппорт depeNo написано, потому что MaxReports уже достиг 
Нет отчета Аппорт написано, потому что MaxReports уже достиг 
Нет отчета Аппорт написано, потому что MaxReports уже достиг 
проблемы ndency предотвратить конфигурации чипов в Linux:
 чипов в Linux зависит от вина | вина-неустойчива; однако:
 Пакет вина еще не настроена.
 Пакет wine1.4, который обеспечивает вино еще не настроена.
 Пакет Wine-Unstable-это не установлено.
с dpkg: ошибка при обработке чипов в Linux (--настроить):
 проблемы зависимостей - оставляем "не задано"
Ошибки возникли при обработке:
wine1.4-для i386:i386 в
wine1.4
wine1.4-Общий
wine1.4-amd64 в
вина
чипов в Linux
Ошибка в функции: 
Реакция системная ошибка: е:суб-процесс /usr/бен/с dpkg вернул код ошибки (1)
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4:
 wine1.4 зависит от wine1.4-amd64 (о= 1.4-0ubuntu4); однако:
 Версии wine1.4-amd64 на системе 1.4.1-0ubuntu1~precise1~ppa3.
 wine1.4 зависит от wine1.4-для i386 (= 1.4-0ubuntu4); однако:
 Пакет wine1.4-для i386 не установлен.
 Версии wine1.4-для i386:i386 на системы 1.4.1-0ubuntu1~precise1~ppa3.
с dpkg: ошибка обработки wine1.4 (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурация вина:
 вина зависит от wine1.4; однако:
 Пакет wine1.4 еще не настроена.
с dpkg: ошибка при обработке вина (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4-Общий:
 wine1.4-Общий зависит от wine1.4 (= 1.4-0ubuntu4); однако:
 Пакет wine1.4 еще не настроена.
с dpkg: ошибка обработки wine1.4-Общий (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4-для amd64:
 wine1.4-amd64 в зависимости от wine1.4-Общий (= 1.4.1-0ubuntu1~precise1~ppa3); однако:
 Версии wine1.4-на общей системе составляет 1,4-0ubuntu4.
с dpkg: ошибка обработки wine1.4-amd64 (о--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4-для i386:i386 с:
 wine1.4-для i386:i386, который зависит от wine1.4-Общий (= 1.4.1-0ubuntu1~precise1~ppa3); однако:
 Версии wine1.4-на общей системе составляет 1,4-0ubuntu4.
с dpkg: ошибка обработки wine1.4-для i386:для i386 (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации чипов в Linux:
 чипов в Linux зависит от вина | вина-неустойчива; однако:
 Пакет вина еще не настроена.
 Пакет wine1.4, который обеспечивает вино еще не настроена.
 Пакет Wine-Unstable-это не установлено.
с dpkg: ошибка при обработке чипов в Linux (--настроить):
 проблемы зависимостей - оставляем "не задано"

Я попробовал следующий:

  • суда apt-получить чистый
  • судо apt-получить автоочистка
  • судо apt-получить установку -Ф

И returnsme:

Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Исправление зависимостей... сделано
Следующие дополнительные пакеты будут установлены:
 wine1.4 wine1.4-Общий
Предлагаемые пакеты:
батей
Следующие пакеты будут обновлены:
 wine1.4 wine1.4-Общий
2 обновлено, 0 установлено новых, 0 для удаления и 110 не обновляется.
6 не полностью установлены или удалены.
Нужно получить 0 б/1,126 КБ архивов.
После этой операции, 9,216 в дополнительное дисковое пространство будет использоваться.
Вы действительно хотите продолжить [д/н]? г
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4-для i386:i386 с:
 wine1.4-для i386:i386, который зависит от wine1.4-Общий (= 1.4.1-0ubuntu1~precise1~ppa3); однако:
 Версии wine1.4-на общей системе составляет 1,4-0ubuntu4.
с dpkg: ошибка обработки wine1.4-для i386:для i386 (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4:
 wine1.4 зависит от wine1.4-amd64 (о= 1.4-0ubuntu4); однако:
 Версии wine1.4-amd64 на системе 1.4.1-0ubuntu1~precise1~ppa3.
 wine1.4 зависит от wine1.4-для i386 (= 1.4-0ubuntu4); однако:
 Пакет wine1.4-для i386 не установлен.
 Версии wine1.4-для i386:i386 на системы 1.4.1-0ubuntu1~precise1~ppa3.
Нет отчета Аппорт написал, потому что сообщение об ошибке указывает на его ошибки кратностью от предыдущего отказа.
 с dpkg: ошибка обработки wine1.4 (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4-Общий:
 wine1.4-Общий зависит от wine1.4 (= 1.4-0ubuntu4); однако:
 Пакет wine1.4 еще не настроена.
с dpkg: ошибка обработки wine1.4-Общий (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации wine1.4-для amd64:
 wine1.4-amd64 в зависимости от wine1.4-Общий (= 1.4.1-0ubuntu1~precise1~ppa3); однако:
 Версии wine1.4-на общей системе составляет 1,4-0ubuntu4.
с dpkg: ошибка обработки wine1.4-amd64 (о--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурация вина:
 вина зависит от wine1.4; однако:
 Пакет wine1.4 еще не настроена.
с dpkg: ошибка при обработке вина (--настроить):
 проблемы зависимостей - оставляем "не задано"
с dpkg: проблемы зависимостей предотвратить конфигурации чипов в Linux:
 чипов в Linux зависит от вина | вина-неустойчива; однако:
 Отчет Аппорт PackagNo написал, потому что сообщение об ошибке указывает на его ошибки кратностью от предыдущего отказа.
 Нет отчета Аппорт написал, потому что сообщение об ошибке указывает на его ошибки кратностью от предыдущего отказа.
 Нет отчета Аппорт написано, потому что MaxReports уже достиг 
 Нет отчета Аппорт написано, потому что MaxReports уже достиг 
 е вино еще не настроена.
 Пакет wine1.4, который обеспечивает вино еще не настроена.
 Пакет Wine-Unstable-это не установлено.
с dpkg: ошибка при обработке чипов в Linux (--настроить):
 проблемы зависимостей - оставляем "не задано"
Ошибки возникли при обработке:
wine1.4-для i386:i386 в
wine1.4
wine1.4-Общий
wine1.4-amd64 в
вина
чипов в Linux
Е: суб-процесс /usr/бен/с dpkg вернул код ошибки (1)

Цна кто-нибудь helpme? Я искал решение для дней и до сих пор не могу решить.

Спасибо! Пабло

+347
javapapo 18 дек. 2010 г., 8:16:13

Вы можете попробовать диам. Вы можете использовать язык UML для создания модели базы данных и использовать один из официально поддерживаемых скриптов , чтобы преобразовать его в SQL.

Например, вы можете найти основные инструкции, используя Диа и TeDia2SQL в http://left.subtree.org/2007/12/05/database-design-with-dia/

+283
Alexander Chang 1 окт. 2014 г., 8:17:55

Попытка решения user1261084:

$ судо apt-получить установку вин
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Некоторые пакеты невозможно установить. Это может означать, что у вас есть
просите невозможного, или если вы используете нестабильный
распределение, что некоторые необходимые пакеты еще не созданы
или были удалены из incoming.
Следующая информация может помочь разрешить ситуацию:

Следующие пакеты имеют неудовлетворенные зависимости:
 вино : зависит: wine1.4 но он не будет установлен
Е: не удалось исправить ошибки, у вас прошла сломанные пакеты.

Попытка @Эрик-Карвалью решение еще раз

политика $ АПТ-кэш libgnutls26
libgnutls26:
 Установлено: 2.12.19-1
 Кандидат: 2.12.19-1
 Версия таблицы:
 *** 2.12.19-1 0
 100 /ВАР/Либ/с dpkg/статус
 2.12.14-5ubuntu3.1 0
 500 http://archive.ubuntu.com/ubuntu/ точный-обновления/главная пакеты для amd64 
 2.12.14-5ubuntu3 0
 500 http://archive.ubuntu.com/ubuntu/ точный/главная пакеты для amd64

Я был удален НПА:Убунту-вино/ППА репозиторий (программный центр > правка > источники приложений > другие программы и вручную удалить) потом пошли приложений Ubuntu вкладку и изменить скачать с на основной сервер в качестве user1261084 предложил.

после этого я попытался понизить libgnutls26 до версии 2.12.14-5ubuntu3.1:

$ судо apt-получить установку libgnutls26=2.12.14-5ubuntu3.1
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Предлагаемые пакеты:
gnutls-Бен
Следующие пакеты будут понижены:
libgnutls26
0 обновлено, 0 установлено новых, 1 понижен, 0 для удаления и 8 не обновляется.
Нужно сделать 459 КБ архивов.
После этой операции, 326 КБ дискового пространства будет освобождена.
Вы действительно хотите продолжить [д/н]? Г
Получите:1 http://archive.ubuntu.com/ubuntu/ точный-обновления/главная libgnutls26 для amd64 2.12.14-5ubuntu3.1 [459 КБ]
Извлечена 459 КБ в 5s (86.8 кб/с) 
с dpkg: предупреждение: понижение libgnutls26 от 2.12.19-1 до 2.12.14-5ubuntu3.1.
(Чтение базы данных ... файлы 267654 и каталоги установлены.)
Готовится сменить libgnutls26 2.12.19-1 (через .../libgnutls26_2.12.14-5ubuntu3.1_amd64.деб) ...
Распаковка замена libgnutls26 ...
Настройка libgnutls26 (2.12.14-5ubuntu3.1) ...
Обработка триггеров для библиотеки libc-Бен ...
команду ldconfig отложенной обработки, которые сейчас происходят

он работал так:

$ судо apt-получить установку вин
Чтение списков пакетов... готово
Построение дерева зависимостей 
Чтение информации о состоянии... готово
Следующие пакеты были установлены автоматически и больше не требуется:
 autopointбыл об / мин librpmsign0 librpmbuild2 
Воспользоваться 'apt-получить autoremove', чтобы удалить их.
Следующие дополнительные пакеты будут установлены:
 шрифты-шрифты дроид-Горай-umefont libasn1-8-Хеймдаль:для i386 libavahi-client3:для i386 libavahi-общего сведения:для i386 libavahi-common3:для i386 libcapi20-3
 libcapi20-3:libcups2 для i386:i386 в libexif12:libgcrypt11 для i386:i386, так libgd2-XPM файла:libgif4 для i386:i386 в libgl1-Меса-Дри:для i386 libgl1-Меса-комплектации GLX:i386 в
 libglapi-Меса:для i386 libglu1-Mesa в:libgnutls26 для i386:i386 в libgpg-error0:для i386 libgphoto2-2:i386 с libgphoto2-port0:для i386 libgssapi-krb5 из-2:для i386
 libgssapi3-Хеймдаль:для i386 libgstreamer-Плагины-base0.10-0:i386 с libgstreamer0.10-0:i386 с libhcrypto4-Хеймдаль:для i386 libheimbase1-Хеймдаль:для i386
 libheimntlm0-Хеймдаль:для i386 libhx509-5-Хеймдаль:для i386 libieee1284-3:libk5crypto3 для i386:i386 в libkeyutils1:для i386 libkrb5-26-Хеймдаль:для i386 libkrb5-3:для i386
 libkrb5support0:для i386 libldap-2.4-2:i386 в libllvm3.0:i386 с libltdl7:для i386 libmpg123-0:i386 в libopenal1:для i386 liborc-0.4-0:i386 с libp11-kit0:для i386
 libroken18-Хеймдаль:libsane для i386:i386 в libsasl2-2:для i386 libsasl2-модулей:для i386 libssl1.0.0:i386 в libtasn1-3:i386 с помощью libusb-0.1-4:для i386 libv4l-0:i386 в
 libv4lconvert0:для i386 libwind0-Хеймдаль:для i386 libx11-xcb1:для i386 libxcb-glx0:libxcomposite1 для i386:i386 в libxcursor1:libxdamage1 для i386:i386 в libxfixes3:для i386
 libxinerama1:для i386 библиотеки libxml2:i386 в libxpm4:libxrandr2 для i386:i386 с libxslt1.1:libxxf86vm1 для i386:i386 в ТТФ-ТТФ дроид-umefont вино-gecko1.4 вина-gecko1.4:для i386
 wine1.4 wine1.4-amd64 в wine1.4-Общий wine1.4-для i386:i386, который находится winetricks
Предлагаемые пакеты:
 чашки-общее:для i386 ГСЧ-инструменты:для i386 утилита-инструменты:libglide3 для i386:i386 с gnutls-ОГРН:gphoto2 для i386:i386 в gtkam:для i386 файл krb5-док:для i386 файл krb5-пользователей:для i386
 libvisual-0.4-плагины:для i386 и GStreamer-кодек-установите:для i386 гном-кодек-установите:для i386 gstreamer0.10-инструменты:для i386 gstreamer0.10-плагинов-база:для i386 hpoj:для i386
 пакет:для i386 libsane-дополнительно:для i386 вменяемый-утилиты:для i386 libsasl2-модули-ОТП:для i386 libsasl2-модулей-в LDAP:для i386 libsasl2-модулей от SQL:для i386
 libsasl2-модули-gssapi с-МИТ:для i386 libsasl2-модули-gssapi с-Хеймдаль:i386 с батей
Рекомендуемые пакеты:
 в XML-ядро:gettext версии для i386:i386 в
Следующие пакеты будут удалены:
 чужой утилиты gettext версии гнома-общие intltool intltool-дебиан по-debconf в
Следующие новые пакеты будут установлены:
 шрифты-шрифты дроид-Горай-umefont libasn1-8-Хеймдаль:для i386 libavahi-client3:для i386 libavahi-общего сведения:для i386 libavahi-common3:для i386 libcapi20-3
 libcapi20-3:libcups2 для i386:i386 в libexif12:libgcrypt11 для i386:i386, так libgd2-XPM файла:libgif4 для i386:i386 в libgl1-Меса-Дри:для i386 libgl1-Меса-комплектации GLX:i386 в
 libglapi-Меса:для i386 libglu1-Mesa в:libgnutls26 для i386:i386 в libgpg-error0:для i386 libgphoto2-2:i386 с libgphoto2-port0:для i386 libgssapi-krb5 из-2:для i386
 libgssapi3-Хеймдаль:для i386 libgstreamer-Плагины-base0.10-0:i386 с libgstreamer0.10-0:i386 с libhcrypto4-Хеймдаль:для i386 libheimbase1-Хеймдаль:для i386
 libheimntlm0-Хеймдаль:для i386 libhx509-5-Хеймдаль:для i386 libieee1284-3:libk5crypto3 для i386:i386 в libkeyutils1:для i386 libkrb5-26-Хеймдаль:для i386 libkrb5-3:для i386
 libkrb5support0:для i386 libldap-2.4-2:i386 в libllvm3.0:i386 с libltdl7:для i386 libmpg123-0:i386 в libopenal1:для i386 liborc-0.4-0:i386 с libp11-kit0:для i386
 libroken18-Хеймдаль:libsane для i386:i386 в libsasl2-2:для i386 libsasl2-модулей:для i386 libssl1.0.0:i386 в libtasn1-3:i386 с помощью libusb-0.1-4:для i386 libv4l-0:i386 в
 libv4lconvert0:для i386 libwind0-Хеймдаль:для i386 libx11-xcb1:для i386 libxcb-glx0:libxcomposite1 для i386:i386 в libxcursor1:libxdamage1 для i386:i386 в libxfixes3:для i386
 libxinerama1:для i386 библиотеки libxml2:i386 в libxpm4:libxrandr2 для i386:i386 с libxslt1.1:libxxf86vm1 для i386:i386 в ТТФ-ТТФ дроид-umefont вина-gecko1.4
 вино-gecko1.4:для i386 wine1.4 wine1.4-amd64 в wine1.4-Общий wine1.4-для i386:i386, который находится winetricks
Обновлено 0, 74 вновь установленных, 7 снять и 8 не обновленные.
Нужно сделать 143 МБ архивов.
После этой операции, 408 МБ дополнительного дискового пространства будет использовано.
Вы действительно хотите продолжить [д/н]? Г
...
Настройка wine1.4-Общий (1.4-0ubuntu4.1) ...
Настройка wine1.4-для amd64 (1.4-0ubuntu4.1) ...
Настройка wine1.4-для i386:i386 с (1.4-0ubuntu4.1) ...
Настройка wine1.4 (1.4-0ubuntu4.1) ...
Создание вина (1.4-0ubuntu4.1) ...
Обработка триггеров для библиотеки libc-Бен ...
команду ldconfig отложенной обработки, которые сейчас происходят

Проверяя версию Wine (установлено: 1.4-0ubuntu4.1)

$ АПТ-кэша политика вино
вино:
 Установлено: 1.4-0ubuntu4.1
 Кандидат: 1.4-0ubuntu4.1
 Версия таблицы:
 *** 1.4-0ubuntu4.1 0
 500 http://archive.ubuntu.com/ubuntu/ точный-обновления/Вселенная пакеты для amd64 
 100 /ВАР/Либ/с dpkg/статус
 1.4-0ubuntu4 0
 500 http://archive.ubuntu.com/ubuntu/ точный/Вселенная пакеты для amd64 

полный отчет здесь

Теперь у меня есть вино, 1.4 установки я добавил ППА:Убунту-вино/ППА репозиторий снова и:

$ судо apt-получить установку wine1.5
(...)
$ АПТ-кэша политика вино
вино:
 Установлено: 1.5.13-0ubuntu1
 Кандидат: 1.5.13-0ubuntu1
 Версия таблицы:
 *** 1.5.13-0ubuntu1 0
 500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ точный/главная пакеты для amd64
 100 /ВАР/Либ/с dpkg/статус
 1.4-0ubuntu4.1 0
 500 http://mirror.globo.com/ubuntu/archive/ точный-обновления/Вселенная пакеты для amd64 
 1.4-0ubuntu4 0
 500 http://mirror.globo.com/ubuntu/archive/ точный/Вселенная пакеты для amd64 

Итак, наконец я установил вино 1.5 (^-^) спасибо Эрик Карвалью и user1261084 помочь.

+275
Matt Zukowski 7 мая 2016 г., 11:10:28

Прямую по USB не может быть обновлен или обновлен. Что у вас есть образ DVD-диска внутри USB. Вам придется установить Ubuntu на другой диск, чтобы получить все преимущества полная установка. Второй диск может быть другой USB-накопитель.Посмотреть как установить Ubuntu на USB-ключ? (без использования загрузочного диска Творца) , как сделать полную установку Ubuntu в качестве USB-накопителя. В частности, последует ответ на Cumulus007. Читаю другие ответы. Чем больше вы знаете тем лучше.

Если я правильно понял, компьютер не имеет жесткого диска. В этом случае вам не нужно беспокоиться об установке Убунту на жесткий диск и протереть все содержимое в процесс.

Вам понадобится два USB-накопителей. Прямую USB может быть 1ГБ. Второй должен быть как минимум 8 ГБ или больше, так как при полной установке будет занимать больше места. Вам также потребуется пространство для обновления и обновления системы, установки новых программ, а также для ваших документов, картинок, музыки и т. д. Я пробовал делать полную установку в 4ГБ USB, и он был слишком мал для установки. У меня 16 Гб при полной установке.

Есть две вещи, которые вы не хотите, чтобы в полном объеме установить USB.

Во-первых, как правило, каждый раз Убунту сапоги, граб загрузчик проверяет все жесткие диски в компьютере, чтобы увидеть, если есть любой другой операционной системы (ОС) и добавляет их в меню загрузки, так что вы можете выбрать ОС, которую вы хотите загрузить. Вы хотите, чтобы ваш USB, чтобы быть портативными. То есть, вы можете взять его на другой компьютер и загрузите ваши собственные Ubuntu тоже есть. Каждый раз, когда вы делаете, что жратва будет добавить ОС этого компьютера в список. Итак, если вы загрузите Ubuntu с USB, используя 4 компьютера с XP, Vista, 7 и 8. Позже может появиться выбор загрузки из всех четырех, даже если ваш компьютер не имеет жесткого диска и ни один из этих Осс.

Чтобы предотвратить это, выполните следующие действия после загрузки с нового установить USB. Откройте терминал, нажав сочетание клавиш Ctrl+АЛТ+Т и тип:

судо команду chmod -х /и т. д./харч.д/30_os-зондового контроля

Во-вторых, не создают раздел подкачки при установке. По умолчанию, установка Ubuntu может создать раздел подкачки. Для этого потребуется более продвинутый вариант установки, называемый "другое" и укажите какие разделы создать во время установки. Посмотрим, как разметить диск для установки Ubuntu? для некоторых инструкций о том, как создавать разделы. Ответ немного старый и изображения могут не совпадать с вашими, но вы получите идею.

Вы должны также отключить подкачку после установки. Увидеть, снижая диска пишет: swapiness=0 или командой swapoff лучше?

Также смотрите своп чаво в сообществе Ubuntu документация.

Надеюсь, что это помогает

+193
Steve Mallam 28 мая 2014 г., 3:16:45

У меня есть вопрос. Я наткнулся на очень полезный лайфхак в компании. (http://www.wikihow.com/Access-Files-on-a-Computer-With-Ubuntu-when-Windows-Fails-to-Boot) Он показывает, как вы можете получить ваши файлы, когда Windows не загружается использую Ubuntu. По данным на сайте, необходимо выбрать в Ubuntu 11.10 для работы. Мой вопрос будет ли это работать на других версиях Ubuntu, или сказать другой дистрибутив Linux.

+103
SarahShep 10 мар. 2014 г., 15:47:06

Я действительно не знаю, что случилось с вашими пакетами, но попробую:

судо apt-получить автоочистка
суда apt-получить чистый
судо apt-получить autoremove
судо команды dpkg --настроить -а
судо apt-получить установку -Ф
судо apt-получить обновление
+79
Daniel Tonon 3 нояб. 2015 г., 5:21:12

Жратва была погрузка на ваш компьютер, он просто не откроется меню, потому что он считал, не было никаких других вариантов. Как я понимаю, ты теперь вернемся к тому, что практически идентичное исходное состояние: вы можете загрузить Linux, но не Windows. Единственная разница заключается в том, что теперь у вас в меню загрузки grub. Если я неправильно понял, прошу пояснить.

К сожалению, загрузка Windows не является сильной стороной загрузчика GRUB. Есть множество предложенные конфигурации жратвы доступны в интернете, но они часто не ... что работает на одной системе не по другому. Я тут навскидку это:

menuentry "ОС Windows 8" {
 part_gpt insmod 
 цепь insmod 
 установить параметр root='(hd0,gpt1)'
 c возможностью старта обоих /ЭФИ/Майкрософт в/boot/bootmgfw.Эфи
}

Нужно ввести это в файле/etc/харч.д/40_custom , а затем запустить команду sudo обновление-жратвы , чтобы сделать его доступным. Обратите внимание, что вам может потребоваться изменить набор корневых= строке и/или c возможностью старта обоих линия для загрузчика. Потому что вы запустите загрузиться ремонта, c возможностью старта обоих линии должен ссылаться окна загрузчика новым именем (наверное bkpbootmgfw.Эфи).

Другим вариантом является, чтобы установить мой изысканный Диспетчер загрузки, который имеет тенденцию быть более надежным при запуске Windows. К сожалению, тот факт, что вы запустите загрузочный ремонт усложняет эту, потому, что загрузочный ремонт перемещает и переименовывает загрузчик Windows и копирует жратвы в старые окна расположения загрузчика. Таким образом, вы, возможно, потребуется изменить это назад, либо вручную, либо путем повторного запуска восстановления загрузки и выбора опций, чтобы отменить изменения.

С либо решение, вы, возможно, потребуется отключить безопасную загрузку в вашу прошивку или установить обновленную версию оболочки. Бывший, вероятно, будет намного легче, но я не могу сказать точно как это сделать, потому что он варьируется от одной ели к другой. Последний вариант сложнее и сложнее. Посмотреть на изысканный ШИМ документации подробнее о том, как сделать это с изысканный.

+73
Mustafa Noor 1 авг. 2013 г., 22:06:51

Я использую CodeBlocks. Я бы порекомендовал вам то же самое. Возможно, вам нужно установить создать-основы для компиляции программ.

суда apt-получить установку строить-важно
+47
Abbot Skinny 30 нояб. 2018 г., 20:10:02

Вы можете иметь интерактивные уведомления с Единства.

Проверена с 12.10, 13.04, 13.10, 14.04, 14.10, 16.04 (спасибо @ManseUK).

Что мы хотим

Уведомления должны не obstrusive, не нарушая ваших мыслей, и укажите ярлык, когда это уместно.

Проблема в единстве (, , по крайней мере)

Механизм уведомлений по умолчанию-уведомлять-ОСД.

  • уведомления не кликабельны (что вредит эффективности для тех, которые предлагают быстро доставить вас к месту интереса).
  • когда несколько происходят быстро, они очереди и появляются одна за другой : никакого способа, чтобы увидеть их быстро, надо просто ... подождать.

Решение

Текущее обновление Xfce уведомления , с другой стороны, реализовать просто, и они могут быть использованы с Единства. Я только что протестировал это с отдельной учетной записи (по умолчанию), чтобы исключить любые пользовательские настройки.

Методические указания

Вот как установить и использовать XFCE4 уведомлений вместо единства:

судо apt-получить установку xfce4-notifyd ; судо apt-получить продувки уведомить-ОСД

Чтобы получить мгновенный эффект это может помочь (другого выхода/входа):

команду killall -в уведомления-ОСД
/УСР/Либ/*/xfce4/notifyd/xfce4-notifyd &

Вы, возможно, захотите, чтобы проверить и отрегулировать внешний вид:

xfce4-notifyd-конфиг
+35
Nestsouls 5 окт. 2010 г., 6:41:40

Я нашел хорошее приложение для создания некоторые хорошие старинные стиле старой фотографии, как Instagram... Может быть, вы должны проверить его здесь:

http://vintagejs.com/

и здесь (вы можете найти его на веб-магазине), и это вызывает немедленный ретро:

и поделиться своими фотографиями с приятным ретро-стиле!

+12
snb chary 15 июн. 2013 г., 5:32:26

Показать вопросы с тегом